SplashID 4 User Guide

For Windows Mobile Pocket PC, aka Windows Mobile Professional

Table of Contents

Quick Start
List View
  > Menu Options
Tree View
Detail View
Edit Dialog
Automatic Password Generator
Types and Categories
Custom Field Labels
SplashID Desktop
  > Overview
  > Buttons
  > Options
  > Web Auto-Fill
  > Database Sync
  > Synchronization
Importing and Exporting
Backup and Restore


SplashID provides quick and easy access to all of your sensitive personal identification information, including usernames, passwords, credit cards, PINs, calling card numbers, frequent flyer numbers, insurance info and more. Data is stored in a secure, encrypted, password protected format and can be synchronized between SplashID on your Windows Mobile handheld and SplashID on your desktop computer.

SplashID on the handheld and SplashID Desktop are virtually identical. This user guide focuses on the features in SplashID on the handheld. You may prefer to do most of your data entry in SplashID Desktop, however, since it's faster and easier with a keyboard, and then perform a Sync operation to synchronize the data with your handheld.


Connect your handheld device to your desktop computer. Run the Installer and follow the on screen instructions. At the end of installation, the software will install on the handheld. The installer installs the following files:

  • -- The application used to view and edit information on the handheld.
  • SplashID Desktop -- A desktop application used to view and edit information on the desktop.
  • SDPlatformMgr.dll and SIDProv.dll -- Extension for the Desktop application.
  • SplashID User Guide -- This User Guide.


When you launch SplashID you will be prompted to enter a registration code or to run in Trial mode. You may run the software for 30-days in full-functioning Trial mode. The Trial software and Registered software are identical. Once the trial period ends you must purchase and enter a registration code to continue using the software. You do not need to re-install the software. Simply enter a registration code and your Trial version will be converted into a Registered version and all your data will remain intact. The registration code must be entered in both the desktop application and the handheld application.

Quick Start

  1. Launch SplashID and the List View will be displayed with several sample records.
  2. Press Tools > New to create a new record, or select an existing record to edit.
  3. In the Edit View select a Type, such as Credit Card or Web Login, and you will see the Field Labels change accordingly.
  4. Press Done when you are finished entering the information for the new record and you are returned to the List View.
  5. You can create records on the handheld or the desktop and synchronize the data between the two. You may find it easier to enter data in SplashID Desktop where you can use your keyboard.

List View

When you launch SplashID you are presented with the List View, which displays a list of your items. Items are records of information, like a credit card number and expiration date; or a website username and password.

List View

Type Menu

Category Menu
  • Types -- Use the Type menu on the top left to filter the view by type, such as Credit Cards or Web Logins. All Types are displayed by default, but you may restrict the list to only display items assigned to a specific Type (see Types and Categories).
  • Categories -- Use the Category menu on the top right to filter the view by Category, such as Business or Personal. All categories are displayed by default, but you may restrict the list to only display items assigned to a specific Category (see Types and Categories).
  • Sorting -- Tap the column header to sort by that column. Tap again to reverse sort. The sorted column displays a triangle indicating the sort order.
  • Resize columns -- You may resize a column by dragging the left/right edges of the column header.
  • Find - The left soft key is designated for the Find tool. Press this button to open the Find dialog. Here you can select to search on all fields, or just specified fields. You can also select to search on the whole word only and make it case sensitive if you wish. When a find has been performed, the left soft key will change to "Find All," which you can press to view all records again.

List View Menu Options

To open the menu options for any screen, tap the Tools menu. In the List view, this will display the following menu options:

List View Menu Options

Choose Row Color

Find Dialog

The List view contains the following menu commands:

  • Tree View -- Select to view your records in a tree format in Tree View.
  • New -- Creates a new record.
  • Mask/Unmask Fields -- Show or hide Masked fields.
  • Lock Now -- Locks SplashID immediately and requires a password to open the data again. See Security for more information.
  • Set Password -- Select Set Password to password protect SplashID. See Security for more information.
  • Security Options -- Security Options allows you to specify a period of time after SplashID becomes idle before the application locks and requires a password. See Security for more information.
  • Getting Started -- Opens the Getting Started wizard that is displayed the first time you run the application.
  • Email Records -- Exports a vID file which you can then email as a means of sharing or backing up data.
  • Import vID File -- Allows you to browse for a file on the device or memory card to import. This is a good workaround to import data exported from the Mac version of the SplashID desktop.
  • Prefs:
    • Set Row Color -- You may select a custom row color for the List View, or select white if you do not wish to have a row color.
    • Set Header Color -- You may select a custom row color for the Header row.
    • Show Columns -- The Show Columns dialog lets you select the columns to display in the List View. Note: The column settings are remembered for each record Type. For example, you can show two columns when viewing Web-Logins and three columns when viewing Credit Cards.
    • Choose Font --  Opens the font picker dialog where you can select a font to use in the application and set the font size.
  • About -- Displays the version and registration code.
  • Exit -- Closes the application fully.

Tree View

Tree View
Tree View

Tree View allows you to see your records in a Tree format. The left soft key will allow you to search your records and display relevant results. Tap a plus symbol to expand a branch, or double tap the branch name.

The Tree View offers the following Tools menu options:

  • List View -- Switches to the List View.
  • New -- Creates a new record.
  • Lock Now -- Locks SplashID immediately and requires a password to open the data again. See Security for more information.
  • Security Options -- Security Options allows you to specify a period of time after SplashID becomes idle before the application locks and requires a password. See Security for more information.
  • Set Password -- Select Set Password to password protect SplashID. See Security for more information.
  • Exit -- Closes the application fully.


Detail View

Detail View
Detail View

Tap an item in the List View to view its details in the Detail View. Each item can contain up to 9 fields, an icon, plus additional notes. *New in SplashID 4 - You can now tap a URL or phone number to open the web page or call the number.

The Detail View offers the following Tools menu options:

  • New Record -- Creates a new record. 
  • Edit Record -- Edit the displayed record. 
  • Duplicate Record -- Duplicates the displayed record. 
  • Delete Record -- Deletes the displayed record. 
  • Mask/Unmask Fields -- Show or hide Masked fields.
  • Email Record -- Exports a vID file of the displayed record, which you can then email as a means of sharing or backing up data.
  • Choose Font --  Opens the font picker dialog where you can select a font to use in the application and set the font size.


Edit Dialog

Enter the Edit Dialog for a given record by selecting Edit Record from the Tools menu or tapping anywhere on the screen in the Detail View.

The Edit Dialog offers the following Tools menu options:

  • Delete Record -- Deletes the displayed record. 
  • Edit Note -- Opens the Notes dialog where you can enter additional text about the record.
  • Choose Icon -- Opens the Icon Picker to select a custom icon for the record.
  • Customize Fields --  Opens a dialog where you can select custom field labels specifically for the selected record and change the masking settings for each field.
  • Generate Password -- Opens the Password Generator.

Edit Dialog

Icon Picker


Automatic Password Generator

To bring up the Automatic Password Generator in Edit Dialog, place the cursor in the field where you want to generate a password, then select Generate Password from the Tools menu.

To create a password:

  1. Select one or more options of letters, numbers, symbols, or a combination thereof.
  2. Set the Length.
  3. Check or Uncheck the pronounceable setting.
  4. Tap Generate.
  5. Select one of 10 passwords from the Password menu at the top.
  6. Tap Generate again to generate a new set.
  7. Tap OK when you have decided.


Types and Categories

Edit Types

Edit Categories

The difference between Types and Categories is best illustrated by example. You may use Categories to separate your Business records from your Personal records, while you use Types to separate your Credit Card records from your Web Login records.

Categories act as filters for grouping related records. The two pre-defined Categories are Business and Personal, though you may add more by choosing Edit Categories from the Category menu.

Types act as templates, which define the structure for the items you want to store in SplashID. You may define up to 9 custom field labels and a default icon for each type, as well as specify the fields you wish to mask. For example, you may create a type for Web Logins, which includes custom field labels for username, password and URL, with a globe icon, and the password field masked; and you may create a Type for Credit Cards which includes custom field labels for credit card number, expiration date and PIN, with a Visa icon, and the credit card number and PIN masked.

Define Type

Edit Types -- Select Edit Types from the type menu to display the Edit Types dialog. You may create an unlimited number of Types. Several sample Types are provided, which you may edit or delete. Select an existing type and tap edit, or tap New to create a new one. The Define type dialog is displayed.

Define Type -- Enter a name for the Type and up to 9 custom field labels. The Mask checkbox specifies whether or not the data in that field will be masked. And you may also specify a default icon for the Type.

Custom Field Labels

Field Labels and masking are set by default when you define a Type. You may change the Field Labels and masking, however, on a record by record basis by selecting Customize Fields from the Tools menu when in the Edit Dialog.



Fields that are Masked appear as four asterisks (****). You may show or hide the masked data by selecting Mask/Unmask Fields from the Tools menu.

If you wish to permanently mask or unmask a field for a given Type, you can change its mask setting in the Edit Type dialog.

If you wish to change the mask settings for the specific record, you can do this in the Custom Field Labels dialog.


Set Password Dialog

Numeric Login

Security Options

You can secure your data in SplashID so that a password must be entered to access the application. You will be required to enter the password when launching SplashID, or when waking your device if SplashID was last running when it went to sleep. Once you set a password, SplashID encrypts your data using Blowfish encryption to ensure data security.

  • Setting a Password -- To set a password, select Set Password from the Tools menu in either the List View or Detail View. The Set Password dialog is displayed. Enter a password in the New Password field, and verify the password by entering it again in the Confirm field. You can also use the password generator tool in this dialog, but keep in mind that these are generally strong passwords and difficult to remember. Note: You must manually set the same SplashID password on the handheld and the desktop, if you wish to synchronize between the two.
  • Entering a Password -- You will be required to enter your password each time you launch SplashID, or when you next use your handheld if SplashID was last running when it became idle. You can choose whether to use the numeric or alphabetic keypads to enter your password.
  • Changing a Password -- To change a password, select Password from the Tools menu, enter your Old Password, then enter and confirm the New Password.
  • Removing a Password -- To remove a password, select Set Password from the Tools menu, enter your Old Password, then leave the New Password and Confirm fields blank.

Security Options -- Choose Security Options from the Tools menu to specify the period of time that must elapse before SplashID auto-locks. Once SplashID locks, you must enter your password to open SplashID.

If you wish, you may specify a longer delay, at the risk of less security. If you have specified a longer delay (e.g., 10 minutes) but then desire to lock SplashID immediately, you may select Lock Now from the Tools menu.

You may also check the box for "Lock Immediately in background" which means that if you switch to another application, SplashID will lock automatically. This is recommended because SplashID continues to run if you switch to another application without exiting.

SplashID Desktop

List View
List View

SplashID Desktop is a Windows desktop application that provides identical functionality to SplashID on your Handheld. Information is synchronized between SplashID on the Handheld and SplashID Desktop (see Synchronization). You may find it more convenient to enter your items in SplashID Desktop using your keyboard and mouse, and then synchronize the data with SplashID on your Handheld. SplashID Desktop is similar to SplashID on the Handheld, with the following additional features:

  • 3 Record Views -- Use the View buttons to select from the traditional List View, or the new Panel and Tree Views. Select a record from the List to display the details in the Detail Pane on the right.
  • Web Auto-Fill -- For Web Logins, click the globe button or right click and select Auto-Fill to open Internet Explorer to the selected URL and fill in the login info with your data. See Web Auto-Fill for more info. Or you may simply click on a URL or email address in the preview pane to launch your web browser or email client.
  • Database Sync -- You may select multiple databases to synchronize with on the desktop, so you can share data with other users, even across a network. See Database Sync for more info.
  • Copy field -- You may click the clipboard icon Copy next to a field in the preview pane to copy that field to the clipboard. You may then paste this field into another application (e.g., copying and pasting the password field from SplashID into a web browser). Note: You may also type Control-1 through Control-9 to copy fields 1 through 9 to the clipboard.
Panel View
Panel View
Tree View
Tree View


There are buttons scattered around the SplashID Desktop window, situated by proximity to where they are to be used:

PanelListTree -- Views: Switch between Panel View, List View, and Tree View, respectively.

Options -- Options: Opens the Options dialog (below).

Options -- Lock Now : Locks SplashID immediately and requires a password to open the data again.

Options -- New Type: Opens the Edit Type Dialog for a new Record Type. Available in Panel View only.

Options -- Duplicate Record: Opens the Edit Record Dialog for a duplicate of the selected record.

Options -- Show Details : Shows or hides the Record Detail Pane.

Options -- New Record: Opens the Edit Record Dialog for a new record.

Options -- Edit Record: Opens the Edit Dialog for the selected record. You can also double click the record.

Options -- Delete Record: Deletes the selected record. You can also hit the Delete key.

Options -- Mask/Unmask: Masks/Unmasks field data that has been specified as masked. See Masking.

Options -- Email Records: Exports selected or all records to vID file, then attaches it to a new email.

Options -- Web Auto-Fill : Launches Internet Explorer and fills in record data for selected URL. More info.



When you click the Options button Options or select Options from the Edit menu, you will see the dialog to the left, with the following options:

  • Auto-lock -- You can choose to have SplashID lock automatically after a specified period of inactivity.
  • Set Font -- Select the Font type, style, size and color from the fonts on your system.
  • Show Columns in List View -- Select which field data columns you would like to display in the List View.
  • Set Row Color -- Select the color of the rows in List View, which will also be applied as the background color in the Panel and Tree Views.
  • Database Location -- Select a Custom database location, including network locations. Note: You cannot select a folder that already contains a SplashID database. See Database Sync if you wish to share data.
  • Default Backup Location -- Change the location that the automatic vID backup is saved to.
  • Search Options -- Select to either search on Field 1 only, or search in all fields when using the lookup tool. Searching on all fields will have a slower response, but you will get results that find the search string in any field, instead of just Field 1. Searching on just Field 1 is the same behavior as SplashID 3.x.
  • Auto-Submit Web Logins -- Check this box to automatically submit forms when using the Web Auto-fill feature (below).

Web Auto-Fill

For Web Logins, you can have SplashID launch Internet Explorer and automatically fill in the username and password fields for you. Please take note of the following:

  • Record type must be assigned to Web Logins.
  • Username and password fields should be filled in.
  • URL field must begin with either http:// or www. Find the correct URL to get to the login screen on the selected website -- this is often not the homepage.
  • On Vista and/or Internet Explorer 7, you must disable Protected Mode in:
    • Tools > Internet Options > Security > Uncheck "Enable Protected Mode"
    • Click Apply, then restart Internet Explorer.
  • This may not work with all sites.

Database Sync

database sync

New in SplashID 4, you can synchronize multiple database files manually, at launch, and/or at exit. This is an advanced feature, not recommended for beginner users. As always, it is recommended that you backup your data with a vID export before trying out this feature, so you can revert if you lose anything. Please Note: You can only sync with other SplashID 4.x database files.

To synchronize multiple database files:

  1. Click Add File and select a remote database to sync with. (Your database does not need to be selected).
  2. Select the Sync Mode
    • Synchronize -- Compares the databases and writes changes to each.
    • Current to Remote -- Overwrites remote data with current user data.
    • Remote to Current -- Overwrites current user data with remote data.
  3. Set In Case of Conflict -- Current wins or Remote wins.
  4. Set Sync on Startup preference.
  5. Set Sync on Exit preference.
  6. Check the boxes for the databases you would like to sync.
  7. Select Sync Selected or Sync Now.


SplashID 4 has 2 types of sync available:

  • Sync Provider for Active Sync and Windows Mobile Device Center - This is the same sync functionality found in SplashID 3. When the sync provider is checked in the sync options of the Windows Mobile Device Center or Active Sync, SplashID will sync automatically when the device is connected. This may not work with Windows Mobile 6 devices.
  • RAPI Sync - This is recommended for most Vista users and especially Windows Mobile 6 devices. There is a sync option in the menu bar of the SplashID desktop. Click this and select Sync to synchronize the device.

With both types of sync, the device must be connected, and SplashID must be installed on internal Device memory in order to sync. Also, the passwords must match on the desktop and handheld applications.


You can share information with other SplashID Desktop users by exporting and importing your SplashID records. Records can be exported/imported on the desktop in several formats:

SplashID vID
You may import and export SplashID records in SplashID Virtual ID (vID) format, which allows you to export and import records in a secure, encrypted format. vID files may be encrypted by assigning a password when exporting. The recipient of the vID file may import the data into their copy of SplashID Desktop by double-clicking the file, or choosing Import/SplashID vID from the File Menu. If a password was assigned to the file, the recipient must enter the password in order to import the data.

vID files are a convenient way to share records with a coworker or spouse by exporting a vID file, assigning a password (optional), and then emailing the resulting vID file to the recipient. You can even use the vID format as a backup mechanism by periodically exporting a vID file and archiving it on a backup disk.

*New in SplashID 4* -- You can also use the Email button on the SplashID desktop to export vID files and attach them to a new email message. You can do this on the handheld as well using Email Records in the Options menu.

You may also import and export SplashID records in CSV format. CSV stands for Comma Separated Values, and is a common file format readable by most spreadsheets, databases and word processors. If you wish to import a CSV file, the data must be in the following format:

Type, Field 1, Field 2, Field 3, Field 4, Field 5, Field 6, Field 7, Field 8, Field 9, Date Modified, Notes, Category

It is easy to create the above format in Excel by creating a spreadsheet with 13 columns (as designated above) with one record per row. Then save the file in CSV format.

Note: When importing data, if the type field is blank the record will be placed in Unfiled. If there is a type name and it does not match an existing type a new type will be created.


SplashID data is stored on both the handheld and the desktop, and each acts as a backup of the other. So, in effect, if you lose the data on one of these devices through a catastrophic event (e.g., hard drive failure), the data will be restored to that device from the other device during your next Sync.

Automatic vID Backups
SplashID Desktop has an automatic backup feature which will allow you to easily recover data in most cases. Whenever the data has been changed, a backup is made each time you exit SplashID Desktop. A vID export file is created (and encrypted with the same password you are using in SplashID) and stored in:

My Documents\SplashData\SplashID\Backup\SplashID-WinCE-UserName.vid

If you later need to restore this data, simply double-click the .vid file and you will be prompted for a password and the data will be imported into SplashID Desktop.

You may change the location that this file is saved to in SplashID desktop Options.

Manual vID Backups
You may also perform a manual backup of your data by selecting Backup from the File menu. This will export your SplashID Database in vID format to whatever location you select. You will be given the option to set a password as well, which will encrypt the data and require the password to restore it.

Select Restore from the File menu to restore a vID file that has been backed up either automatically or manually as described above. The password will remain the same for the application even if the password for the backup file was different.

The SplashID Desktop database file is automatically saved to the My Documents directory on your hard drive each time you exit the application. You may back up this file as an added precaution in case of a hard drive failure. To restore the backup file simply copy it into the SplashID directory. Then the next time you launch SplashID it will open the file. This file is stored here:

My Documents\SplashData\SplashID\<Device ID>\SplashID Database.sdb

You may change the location of the SplashID Desktop database file by selecting Change Database Location from the File menu and selecting a different directory. You may choose a local directory on your computer or a network directory. If the desktop database file is unavailable during a sync operation the SplashID synchronization process will be skipped.